通达信指标改选股公式,通达信神奇买入马上大涨指标

通达信指标公式改选股公式?

可以修改这段通达信代码,但无法测试。因为你没提供所引用的扩展数据。

通达信技术指标改选股公式?


  1. 依次点击菜单栏里的“功能”——公示系统——公式管理器——用户——条件选股公式——其它类型——新建,在打开的公式编辑器。

  2. 将下列源码复制后粘贴到中间文本框里,在上面的公式名称栏里写上公式名后,点“确定”,大功告成,得到满足公式中“J”条件的选股公式。

  3. 需要复制粘贴的源码:

  4. MH:=CLOSE#MONTH;

  5. ML:=CLOSE#MONTH;

  6. DZ:=(MH-C)/C*100>20 AND BARSCOUNT(CLOSE)>20;

  7. AB1:=EMA(C,14);

  8. AB1X:=(AB1-REF(AB1,1))/REF(AB1,1)*100;

  9. J:TFILTER(AB1X>=0,DZ,1);


各位高手帮我这个通达信指标改个选股公式吧

{DXH-多信号}
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);MCDA金叉:=DIFF>DEA;
RSV:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;
K:=SMA(RSV,3,1);D:=SMA(K,3,1);KDJ金叉:=K>D;
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),9,1))/(SMA(ABS(CLOSE-LC),9,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),26,1))/(SMA(ABS(CLOSE-LC),26,1))*100;
RSI金叉:=RSI1>RSI2;
VARA1:=LLV(LOW,10);VARA2:=HHV(HIGH,25);
趋势:=EMA((CLOSE-VARA1)/(VARA2-VARA1)*110,4);
顶底:=趋势>=REF(趋势,1);
BBI:=(MA(CLOSE,3)+MA(CLOSE,9)+MA(CLOSE,12)+MA(CLOSE,26))/4;
BBI金叉:=CLOSE>BBI;
VAR1:=1;VAR2:=((((2*CLOSE)+HIGH)+LOW)/4);
VAR4:=LLV(LOW,5);VAR5:=HHV(HIGH,4);
C1:=(EMA((((VAR2-VAR4)/(VAR5-VAR4))*100),4)*VAR1);
C2:=(EMA(((0.667*REF(C1,1))+(0.333*C1)),2)*VAR1);
AA:=C1>=C2
;BB:=C2>C1;抢反弹:=C1>=C2;
VOLUME:=VOL;MAVOL1:=MA(VOLUME,5);MAVOL2:=MA(VOLUME,10);
成交量:=MAVOL1>MAVOL2;
周K:=MA("KDJ.K#WEEK"(9,3,3),5);
周D:=MA("KDJ.D#WEEK"(9,3,3),5);
周J:=MA("KDJ.J#WEEK"(9,3,3),5);
周KD金叉:=周K>=周D;
周K拐点:=周K>=REF(周K,1);周J拐点:=周J>=REF(周J,1)
;
DXHXG:周K拐点
AND
周J拐点
AND
周KD金叉
AND
MCDA金叉
AND
KDJ金叉
AND
RSI金叉
AND
顶底
AND
BBI金叉
AND
抢反弹
AND
成交量;
属于多信号的选法。通过测试。{个人看法,仅供参考。}

将下面通达信指标修改为选股公式

DIFF:=(EMA(CLOSE,3)-EMA(CLOSE,13));
DEA:=EMA(DIFF,9);
XG:CROSS(DIFF,DEA);

通达信附图指标如何改为选股公式

  1. 依次点击菜单栏里的“功能”——公示系统——公式管理器——用户——条件选股公式——其它类型——新建,在打开的公式编辑器。

  2. 将下列源码复制后粘贴到中间文本框里,在上面的公式名称栏里写上公式名后,点“确定”,大功告成,得到满足公式中“J”条件的选股公式。

  3. 需要复制粘贴的源码:

  4. MH:=CLOSE#MONTH;

  5. ML:=CLOSE#MONTH;

  6. DZ:=(MH-C)/C*100>20 AND BARSCOUNT(CLOSE)>20;

  7. AB1:=EMA(C,14);

  8. AB1X:=(AB1-REF(AB1,1))/REF(AB1,1)*100;

  9. J:TFILTER(AB1X>=0,DZ,1);

把下面通达信指标公式改成条件选股公式

A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
SHORT:=7; LONG:=19;
RMA:=EMA(CLOSE,SHORT);
NMA:=EMA(CLOSE,LONG);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(NMA,RMA))+1),LLV(L,BARSLAST(CROSS(NMA,RMA))+1),H=HHV(H,BARSLAST(CROSS(RMA,NMA))+1),HHV(H,BARSLAST(CROSS(RMA,NMA))+1),0);
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(RMA,NMA))+1),HHV(H,BARSLAST(CROSS(RMA,NMA))+1),L=LLV(L,BARSLAST(CROSS(NMA,RMA))+1),LLV(L,BARSLAST(CROSS(NMA,RMA))+1),0);
XG:(LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2))) AND REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
这公式直接就能用做选股公式,但注意未来函数.

返回顶部