通达信角度线的公式,通达信怎样求dif的角度

一条线向上倾斜的角度,用通达信选股公式如何表达?

一条线向上倾斜的角度,也就是斜率。
通达信公式如下:
斜率:=(CLOSE-REF(CLOSE,N))*100/REF(CLOSE,N);
N取值为N天前的收盘价。

通达信的角度公式 如何编写呢?

名称自定 可以做副图也可做选股公式 但我测试了下 应该把均线角度修改为不小于45度 这样才有用
角度:=atan((MA(C,5)/ref(MA(C,5),1)-1)*100)*57.3;
选股:角度>=45 and cross(ma(c,5),ma(c,10));

通达信公式 20日线和60日线的角度30度或者30度以上的公式么?具体可以参考下面的图形。

书写出通达信公式尖代码程序计算选股,帮你快速选出大牛股主升浪股票,你的答案如下:

{角度倾斜率20天线}

X1:(ATAN((MA(C,20)/REF(MA(C,20),1)-1)*100)*180/3.14115926)>=30;

{角度倾斜率60天线}

X1:(ATAN((MA(C,60)/REF(MA(C,60),1)-1)*100)*180/3.14115926)>=30;


求教高手帮忙编个:通达信的主图如何显示均线角度公式

你并没有说事那条线的角度,下面的公式是5日线的角度公式,自己参照着做:
ma5:=(c,5);
五日线角度:atan((ma5/ref(ma5,1)-1)*100)*180/3.1416;

求助:均线角度公式

按照你的问题,公式如下:
均线:MA(CLOSE,30);角度:ATAN((均线/REF(均线,1)-1)*100)*180/3.1416,NODRAW;IF(角度>30,均线,DRAWNULL),LINICK2,COLORRED;IF(角度<-30,均线,DRAWNULL),LINICK2,COLORGREEN;
30天均线向上大于30度时画红粗线,向下跌角度大于30度则画绿粗线,否则不画,
已经测试过,无误,如图!

求通达信均线角度公式

主图叠加

十:=ATAN((MA(C,10)/REF(MA(C,10),1)-1)*100)*180/3.1415926;
二十:=ATAN((MA(C,20)/REF(MA(C,20),1)-1)*100)*180/3.1415926;
三十:=ATAN((MA(C,30)/REF(MA(C,30),1)-1)*100)*180/3.1415926;
IF(十>=30,MA(C,10),DRAWNULL),COLORRED,LINICK2;
IF(十<30,MA(C,10),DRAWNULL),COLORGREEN,LINICK2;
IF(二十>=30,MA(C,20),DRAWNULL),COLORRED,LINICK2;
IF(二十<30,MA(C,20),DRAWNULL),COLORGREEN,LINICK2;
IF(三十>=30,MA(C,30),DRAWNULL),COLORRED,LINICK2;
IF(三十<30,MA(C,30),DRAWNULL),COLORGREEN,LINICK2;

预警公式

十:=ATAN((MA(C,10)/REF(MA(C,10),1)-1)*100)*180/3.1415926;
二十:=ATAN((MA(C,20)/REF(MA(C,20),1)-1)*100)*180/3.1415926;
三十:=ATAN((MA(C,30)/REF(MA(C,30),1)-1)*100)*180/3.1415926;
T1:=十>=30 AND 二十>=30 AND 三十>=30;
XG:=T1 AND REF(T1,1)=0;

返回顶部