最精准的顶底指标公式

  • 请老师将趋势顶底指标公式改成通达信选股公式,选出如下图所示的股票。多谢!

    朋友,以下是你要的选股公式:
    底:=10,COLORCC6633,LINICK2;
    A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);
    B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
    D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);
    长期线:=A+100,COLOR9900FF;
    短期线:=B+100,COLORRED;
    中期线:=D+100,COLORYELLOW,LINICK2;
    见顶:=((REF(中期线,1)>85 AND REF(短期线,1)>85 AND REF(长期线,1)>65) AND CROSS(长期线,短期线));
    顶部区域:=(中期线<REF(中期线,1) AND REF(中期线,1)>80) AND (REF(短期线,1)>95 OR REF(短期线,2)>95 ) AND 长期线>60 AND 短期线<83.5
    AND 短期线<中期线 AND 短期线<长期线+4,COLORGREEN;
    顶部:=FILTER(顶部区域,4);
    ZMIN:(长期线<12 AND 中期线<8 AND (短期线<7.2 OR REF(短期线,1)<5) AND (中期线>REF(中期线,1) OR 短期线>REF(短期线,1)))
    OR (长期线<8 AND 中期线<7 AND 短期线<15 AND 短期线>REF(短期线,1)) OR (长期线<10 AND 中期线<7 AND 短期线<1) ,COLORGREEN;
    不过这公式感觉成功率不高,请结合其他条件来综合分析,祝投资顺利!

  • 哪位有散户大家庭中的顶底波段指标公式

    到论坛去找啥

  • 有通达信顶底分型公式的朋友么

    顶:=BBI+3*STD(BBI,13),COLOR004AFF;
    底:=BBI-3*STD(BBI,13),COLOR67FF00;
    DRAWBAND(BBI,RGB(97,95,00),顶,RGB(97,95,00));
    DRAWBAND(BBI,RGB(25,75,150),底,RGB(25,75,250));
    {MA1:MA(CLOSE,M1);
    MA2:MA(CLOSE,M2),COLORGREEN;
    MA3:MA(CLOSE,M3),COLORRED;
    MA4:MA(CLOSE,M4),COLORYELLOW;}
    KU1:=IF(HIGH=HHV(HIGH,3),1,0);
    KD1:=IF(LOW=LLV(LOW,3),1,0);
    UL:=IF(REF(KU1,2)=1 AND REF(KU1,1)=0
    AND KU1=0,REF(HIGH,2),REF(HIGH,2+BARSLAST(REF(KU1,2)=1
    AND REF(KU1,1)=0 AND KU1=0)));
    DL:=IF(REF(KD1,2)=1 AND REF(KD1,1)=0
    AND KD1=0,REF(LOW,2),REF(LOW,2+BARSLAST(REF(KD1,2)=1
    AND REF(KD1,1)=0 AND KD1=0)));
    HV:=H>UL AND H>REF(H,1) ;
    LV:=L<DL AND L<REF(L,1) ;
    GP:=BARSLAST(HV);
    DP:=BARSLAST(LV);
    IP:=IF(GP=0,DP,GP)>3;
    HHV1:=HV AND IP AND H>=HHV(H,BARSLAST(LV));
    LV1:=LV AND IP AND L<=LLV(L,BARSLAST(HV));
    DRAWLINE(LV1,LOW,HHV1, HIGH,0),COLORYELLOW,LINICK2;
    DRAWLINE(HHV1,HIGH,LV1, LOW,0),COLORMAGENTA,LINICK2;
    STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORRED;
    STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR000055;
    STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR000077;
    STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR000099;
    STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;
    STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;
    STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;
    STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORWHITE;
    STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR555555;
    STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;
    STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;
    STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
    STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
    STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
    STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
    STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR990000;
    STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
    STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
    STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
    STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
    STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORCYAN;
    {笔底分型 选股 预警 确保向下笔成立后的底分型}
    V00:= HIGH<REF(HIGH,1) AND LOW<REF(LOW,1);
    V01:= HIGH<REF(HIGH,1) AND LOW>REF(LOW,1);
    V02:= HIGH>REF(HIGH,1) AND LOW<REF(LOW,1);
    V03:= HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);
    V04:= REF(HIGH,2) < HIGH AND REF(LOW,2) < LOW
    AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1);
    V1:= COUNT(V00,6)>=3 AND COUNT(V01 OR V02,5)=0 AND LLVBARS(LOW,6) = 1 AND HHVBARS(HIGH,6) >= 5 AND V03;
    V2:= COUNT(V00,7)>=3 AND COUNT(V01 OR V02,6)=1 AND LLVBARS(LOW,7) = 2 AND HHVBARS(HIGH,7) >= 6 AND V04;
    V3:= COUNT(V00,7)>=3 AND COUNT(V01 OR V02,6)=1 AND LLVBARS(LOW,7) = 1 AND HHVBARS(HIGH,7) >= 6 AND V03;
    V4:= COUNT(V00,8)>=3 AND COUNT(V01 OR V02,7)<=2 AND LLVBARS(LOW,8) = 2 AND HHVBARS(HIGH,8) >= 7 AND V04;
    V5:= COUNT(V00,8)>=3 AND COUNT(V01 OR V02,7)<=2 AND LLVBARS(LOW,8) = 1 AND HHVBARS(HIGH,8) >= 7 AND V03;
    V6:= COUNT(V00,9)>=3 AND COUNT(V01 OR V02,8)<=3 AND LLVBARS(LOW,9) = 2 AND HHVBARS(HIGH,9) >= 8 AND V04;
    V7:= COUNT(V00,9)>=3 AND COUNT(V01 OR V02,8)<=3 AND LLVBARS(LOW,9) = 1 AND HHVBARS(HIGH,9) >= 8 AND V03;
    V8:= COUNT(V00,10)>=3 AND COUNT(V01 OR V02,9)<=4 AND LLVBARS(LOW,10) = 2 AND HHVBARS(HIGH,10) >= 9 AND V04;
    V9:= COUNT(V00,10)>=3 AND COUNT(V01 OR V02,9)<=4 AND LLVBARS(LOW,10) = 1 AND HHVBARS(HIGH,10) >= 9 AND V03;
    V10:= COUNT(V00,11)>=3 AND COUNT(V01 OR V02,10)<=5 AND LLVBARS(LOW,11) = 2 AND HHVBARS(HIGH,11) >= 10 AND V04;
    XG:= V1 OR V2 OR V3 OR V4 OR V5 OR V6 OR V7 OR V8 OR V9 OR V10;
    DRAWTEXT(FILTER(XG=1,5),L*0.97,'底分型');
    {笔顶分型 选股 预警 确保向上笔成立后的顶分型}
    HV00:= HIGH>REF(HIGH,1) AND LOW>REF(LOW,1);
    HV01:= HIGH<REF(HIGH,1) AND LOW>REF(LOW,1);
    HV02:= HIGH>REF(HIGH,1) AND LOW<REF(LOW,1);
    HV03:= HIGH<REF(HIGH,1) AND LOW<REF(LOW,1);
    HV04:= REF(HIGH,2) > HIGH AND REF(LOW,2) > LOW AND REF(HIGH,2) > REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1);
    HV1:= COUNT(HV00,6)>=3 AND COUNT(HV01 OR HV02,5)=0 AND HHVBARS(HIGH,6) = 1 AND LLVBARS(LOW,6) >= 5 AND HV03;
    HV2:= COUNT(HV00,7)>=3 AND COUNT(HV01 OR HV02,6)=1 AND HHVBARS(HIGH,7) = 2 AND LLVBARS(LOW,7) >= 6 AND HV04;
    HV3:= COUNT(HV00,7)>=3 AND COUNT(HV01 OR HV02,6)=1 AND HHVBARS(HIGH,7) = 1 AND LLVBARS(LOW,7) >= 6 AND HV03;
    HV4:= COUNT(HV00,8)>=3 AND COUNT(HV01 OR HV02,7)<=2 AND HHVBARS(HIGH,8) = 2 AND LLVBARS(LOW,8) >= 7 AND HV04;
    HV5:= COUNT(HV00,8)>=3 AND COUNT(HV01 OR HV02,7)<=2 AND HHVBARS(HIGH,8) = 1 AND LLVBARS(LOW,8) >= 7 AND HV03;
    HV6:= COUNT(HV00,9)>=3 AND COUNT(HV01 OR HV02,8)<=3 AND HHVBARS(HIGH,9) = 2 AND LLVBARS(LOW,9) >= 8 AND HV04;
    HV7:= COUNT(HV00,9)>=3 AND COUNT(HV01 OR HV02,8)<=3 AND HHVBARS(HIGH,9) = 1 AND LLVBARS(LOW,9) >= 8 AND HV03;
    HV8:= COUNT(HV00,10)>=3 AND COUNT(HV01 OR HV02,9)<=4 AND HHVBARS(HIGH,10) = 2 AND LLVBARS(LOW,10) >= 9 AND HV04;
    HV9:= COUNT(HV00,10)>=3 AND COUNT(HV01 OR HV02,9)<=4 AND HHVBARS(HIGH,10) = 1 AND LLVBARS(LOW,10) >= 9 AND HV03;
    HV10:= COUNT(HV00,11)>=3 AND COUNT(HV01 OR HV02,10)<=5 AND HHVBARS(HIGH,11) = 2 AND LLVBARS(LOW,11) >= 10 AND HV04;
    HXG:=HV1 OR HV2 OR HV3 OR HV4 OR HV5 OR HV6 OR HV7 OR HV8 OR HV9 OR HV10;
    DRAWTEXT(FILTER(HXG=1,3),H*1.02,'顶分型');

  • 通达信波段精准抄底逃顶指标公式 好用吗

    没有参考价值

  • 关于通达信BIAS高抛低吸的公式

    这是BIAS高抛低吸的公式:
    BIAS1 :(CLOSE-MA(CLOSE,N1))/MA(CLOSE,6)*100;
    BIAS2 :(CLOSE-MA(CLOSE,N2))/MA(CLOSE,12)*100;
    BIAS3 :(CLOSE-MA(CLOSE,N3))/MA(CLOSE,24)*100;

  • 通达信高抛低吸主图指标怎么使用

    1、新建一个文本文件,填入数据,然后全部选中,复制一下。 2、点击【功能】-【公式系统】-【公式管理器】。 3、点击【技术指标公式】-【其他类型】-【新建】。 4、 将之前文本文件里面的内容,复制到指标的编辑框中来。 填上公式名称、选中主图...(火星人)8460

返回顶部