通达信上升趋势公式

  • 通达信软件,上升趋势过程当中,回调到30日线的选股指标

    从逻辑上分析,按你这个要求确实很容易编出。如果仅仅是按你所简单限定的条件,选出来的股,你会发现有很很多很多,而未来走好走差的经过验证也会是一半对一半错。希望你能更准确的分析可能出现的各类后期走势后重新限定条件或增加条件,以提高准确度。就你的这个,可以这样写选股指标。如下:
    a1:=if(ma(c,30)>ref(ma(c,30),1),1,0);
    a2:=if(c>ma(c,30)&&ref(c,1)<ref(ma(c,30),1),1,0);
    a3:if(a1=1&&a2=1,1,0);
    复制上面语句即可。 你要能更准确细致的描述你的条件,再找我好了。
    嗯,看到了,不知我有没有理解你的意思,你看这样写行不?
    a1:=if(ma(c,30)>ref(ma(c,30),1),1,0);
    条件成立:if(a1=1&&l<ma(c,30)&&ref(l,1)>ref(ma(c,30),1),1,0);
    也就是说,昨天的最低价还在30日线上,而今天的最低价打到了30日线下方。

  • 为了更直观地看到上升趋势,望有高手给写个均线趋势公式,大智慧,通达信都可,有两个最好。

    {通达信}
    MA5:MA(C,5);
    MA14:MA(C,14);
    MA26:MA(C,26);
    MA60:MA(C,60);
    NOTEXT1:IF(MA5>MA14,MA14,DRAWNULL),LINICK2,COLORGREEN;
    NOTEXT2:IF(MA14>MA26,MA26,DRAWNULL),LINICK2,COLORRED;
    NOTEXT3:IF(MA26>MA60,MA60,DRAWNULL),LINICK2,COLORLIRED;
    下破:=L<MA14 AND C>MA14;
    DRAWTEXT(下破,L*0.999,'下破');
    {下破选股}
    下破:L<MA(c,14) AND C>MA(c,14);
    {14日线变组选股}
    上穿:cross(ma(c,5).ma(c,14));
    维持:ma(c,5)>ma(c,14);
    颜色没有怎么调,就加粗的调了下,将就着吧。

  • 求大侠编写个通达信公式:上升趋势中20线的价格相对60线的价格涨幅百分比。例:

    MA1:MA(CLOSE,20);
    MA2:MA(CLOSE,60);
    乖离:(MA2-MA1)/MA2*100,NODRAW;

  • 请编个通达信选股公式:60日均线呈上升趋势,股价今回调至60日均线(上下6%左右)

    MA60:=MA(CLOSE,60);
    AA:=MA60>=REF(MA60,1) AND REF(MA60,1)>=REF(MA60,2) AND REF(MA60,2)>=REF(MA60,3) ;
    BB:=EXIST(CROSS(C,MA60),15);
    MA5:=MA(C,5);
    CC1:=MA5<=REF(MA5,1) AND REF(MA5,1)>=REF(MA5,2);
    CC:=EXIST(CC1,N2);
    DD:=EXIST(ABS(C/MA60-1)<0.06,N3);
    AA AND BB AND CC AND DD;

  • 求通达信条件选股,形态选股,公式

    M1:=MA(C,5);
    M2:=MA(C,10);
    M3:=MA(C,20);
    M4:=MA(C,30);
    T1:=COUNT(C>M4,5)=5 AND LLVBARS(M3,5)-HHVBARS(M3,5)>3 AND HHV(M2,5)/LLV(M2,5)<1.03;
    T2:=MAX(MAX(M1,M2),M3)-MIN(MIN(M1,M2),M3)<0.03;
    XG:T1=1 AND T2=1;

  • 通达信满足一个条件,不满足其它条件选股公式怎么编?

    是有很多条件例如5个条件就满足其中任意一个其他四个不满足是吗,通达信可以编写具体条件是什么。

返回顶部