通达信短线选股公式

  • 通达信短线极准指标公式怎样使用

    公式中已经标注了”短进“,怎么使用看你自己了。
    VAR1:=1;
    VAR2:=(2*CLOSE+HIGH+LOW)/4;
    天: 80, POINTDOT;
    人: 20;
    VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1);
    VAR4:=LLV(LOW,5);
    VAR5:=HHV(HIGH,4);
    散户: EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3*VAR1;
    庄家: EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3*VAR1;
    VAR6:=(HHV(HIGH,4)-VAR2)/(HHV(HIGH,4)-LLV(LOW,4))*100-72;
    VAR7:=(VAR2-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100;
    倒影: SMA(VAR6,4,1)*VAR1;
    VAR8:=SMA(VAR7,2,1);
    黄山: SMA(VAR8,2,1)*VAR1;
    地平线: 12;
    DRAWTEXT(CROSS(散户,庄家) AND 散户<50 AND 29<散户,20,'短进'),COLOR00FF00;
    DRAWTEXT(CROSS(庄家,散户) AND 散户>40 AND 71>散户,50,'短出'),COLOR00FFFF;
    DRAWTEXT(CROSS(散户,庄家) AND 散户<30,0,'低吸'),COLOR3399CC;
    DRAWTEXT(CROSS(庄家,散户) AND 散户>70,75,'高减'),COLORFFFF33;
    DRAWICON(CROSS(散户,庄家) AND 散户<30,20,1);
    DRAWICON(CROSS(庄家,散户) AND 散户>70,80,2);
    VAR9:=CLOSE-REF(CLOSE,5);
    VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5)*100;
    VARB:=EMA(EMA(VAR9,10),10)/EMA(EMA(ABS(VAR9),10),10)*100;
    VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20)*100;
    卖出: IF(VARA>0 AND CROSS(VARC,VARA),-40,0);
    DRAWTEXT(卖出,-30,'中线逃'),COLOR0033FF;
    DRAWICON(卖出<0,-25,2);

  • 通达信超短线选股公式编写

    XG1:FINANCE(7)<1000000000 AND FINANCE(7)>100000000 AND C>MA(C,5) AND CROSS(MA(C,5),MA(C,10)) AND C<REF(C,1) AND V<REF(V,1) *0.7 AND C<REF(C,1);
    搞定了 试试看

  • 通达信选股公式选绝佳机会?

    XG:CROSS((SMA(SMA((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100,3,1),3,1)+3*STD(CLOSE,21)),(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1)))AND (SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1))<18 AND (SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1))>REF((SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1)),1)OR CROSS((SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5,1)),5);

  • 请高手把下面的通达信公式改为有关 买点 买入 短线暴涨 绝对底部等买入信号的选股公式

    选股公式的输出只能是一个,所以你以上的四个买入信号必须分四个选股公式编辑:
    (一)"短线暴涨"选股公式:
    MA5:=MA(C,5);
    MA6:=MA(C,6);
    MA10:=MA(C,10);
    MA20:=MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);
    MA30:=MA(C,30);
    MA60:=MA(C,60);
    MA120:=MA(C,120);
    乖离2:=(MA20-MA30)/MA30*100;
    VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
    MAX1:=MAX(MA20,MA30);
    MAX2:=MAX(MAX1,MA60);
    MIN1:=MIN(MA20,MA30);
    MIN2:=MIN(MIN1,MA60);
    K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}
    VAR2:=IF(K1<=8,1,0);
    短线暴涨:IF(FILTER( (VAR1 OR VAR2) AND MA10>REF(MA10,1) AND COUNT(MA30>REF(MA30,1),3)=3 AND MA30>MA60 AND COUNT(CROSS(MA5,MA30),3) AND J1>MJ1 AND MA(V,5)>MA(V,60)
    AND MA(V,60)>REF(MA(V,60),1),5),1,0);
    (二)"买入"选股公式:
    MA5:=MA(C,5);
    MA6:=MA(C,6);
    MA10:=MA(C,10);
    MA20:=MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);
    MA30:=MA(C,30);
    MA60:=MA(C,60);
    MA120:=MA(C,120);
    乖离2:=(MA20-MA30)/MA30*100;
    VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
    MAX1:=MAX(MA20,MA30);
    MAX2:=MAX(MAX1,MA60);
    MIN1:=MIN(MA20,MA30);
    MIN2:=MIN(MIN1,MA60);
    K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}
    VAR2:=IF(K1<=8,1,0);
    买入:IF(CROSS("KDJ.K"(5,2,3),"KDJ.D"(5,2,3)) AND "KDJ.D"(5,2,3)<30 AND J1>MJ1 AND MA60>REF(MA60,1) AND COUNT(J1<1,3)>=1 ,1,0);
    (三)"买点"选股公式:
    MA5:=MA(C,5);
    MA6:=MA(C,6);
    MA10:=MA(C,10);
    MA20:=MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);
    MA30:=MA(C,30);
    MA60:=MA(C,60);
    MA120:=MA(C,120);
    乖离2:=(MA20-MA30)/MA30*100;
    VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
    MAX1:=MAX(MA20,MA30);
    MAX2:=MAX(MAX1,MA60);
    MIN1:=MIN(MA20,MA30);
    MIN2:=MIN(MIN1,MA60);
    K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}
    VAR2:=IF(K1<=8,1,0);
    XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
    XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
    XL3:=CROSS(XL2,(0 - 20));
    买点:IF(FILTER(((XL1 > 0) AND LOW),5),1,0);
    (四)"绝对底部"选股公式:
    MA5:=MA(C,5);
    MA6:=MA(C,6);
    MA10:=MA(C,10);
    MA20:=MA(C,20);A2:=REF(MA20,1);J1:=(MA20-A2)/A2*100;MJ1:=MA(J1,3);
    MA30:=MA(C,30);
    MA60:=MA(C,60);
    MA120:=MA(C,120);
    乖离2:=(MA20-MA30)/MA30*100;
    VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
    MAX1:=MAX(MA20,MA30);
    MAX2:=MAX(MAX1,MA60);
    MIN1:=MIN(MA20,MA30);
    MIN2:=MIN(MIN1,MA60);
    K1:=(MAX2/MIN2-1)*100;{粘合度符合条件}
    VAR2:=IF(K1<=8,1,0);
    XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
    XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
    XL3:=CROSS(XL2,(0 - 20));
    绝对底部:IF((XL3 > 0),1,0);

  • 你好,有个通达信编程的问题请教。

    可以编写选股公式但前提是你需要选股条件按你指是谁了macd面积计算公式没说选股条件啊例如背驰选股本次绿柱面积小于上一次同时对应股价下跌。

  • 通达信编程?

    可以编写这叫把形态转换成逻辑条件,这需要你对形态的理解转换成逻辑条件才能编写。形态分析是一种主观的分析。这不像技术指标同样的走势只要参数一样谁算macd结果都是一样的。形态确认不一样同样的走势可能确认出n种不同的高低点。

    但确认趋势的方法还是大体相同的,但具体的标准要你自己设定才能编写。

    例如下面几张图中的10日下跌趋势确认效果。

返回顶部